Babel

From Tmplab

(Difference between revisions)
Jump to: navigation, search
(New page: = Babel = The upstream Babel page: http://www.pps.jussieu.fr/~jch/software/babel/ == Babel versions == 0.93 is the most recent released version of Babel. It has some algorithmic change...)
(Packaging)
Line 20: Line 20:
The OpenWRT package for Babel is out-of-date. Babel's author uses ipkg-buildpackage to build his own packages.
The OpenWRT package for Babel is out-of-date. Babel's author uses ipkg-buildpackage to build his own packages.
 +
 +
[[Image:Babel-ipkg.tgz]]

Revision as of 17:06, 4 April 2009

Contents

Babel

The upstream Babel page: http://www.pps.jussieu.fr/~jch/software/babel/

Babel versions

0.93 is the most recent released version of Babel. It has some algorithmic changes w.r.t. 0.92, and is the version that we intend to test.

Configuration

Babel doesn't need much, if any, configuration. Simply listing the interfaces participating in the mesh is enough:

babel wlan0 eth0

Exceptions:

  • Babel uses some optimisations on wired interfaces. If you have interfaces that Babel mis-detects as wired (e.g. weird tunnelling setups, bridging), you need to specify the -w flag on Babel's command line;
  • Babel assumes bridged interfaces are wireless, i.e. disables the optimisations on bridged interfaces. The best solution is to un-bridge the interfaces.

Packaging

The OpenWRT package for Babel is out-of-date. Babel's author uses ipkg-buildpackage to build his own packages.

Image:Babel-ipkg.tgz

Personal tools